Head in a blender

Slight issue with Domino directory locking policy fields by default

Andy Pedisich  December 2 2011 09:00:00 AM
The issue here is not a biggie for me, but it is worth talking about. I'm into exposing stuff, especially when I don't see people talking about it.

The desktop policy settings document for widgets has the six fields listed below set incorrectly in the public address book template for at least R8.5.2 and R8.5.3.  Specifically it's the "How to apply this setting" that I believe is incorrect.  They are all set to a 2 by default, which means to set value and prevent changes.

Image:Slight issue with Domino directory locking policy fields by default



They also list in the $DPLocked field in the policy settings documents when they are saved.  Sometimes all 6 will show up.  Sometimes only 3.
Image:Slight issue with Domino directory locking policy fields by default

Only 3 of these fields are available when you're actually setting them, but note that they are all 3 set to "set value and prevent changes" by default.

Image:Slight issue with Domino directory locking policy fields by default

You'll also see references to them in client console logs
.
[2134:0002-1898] 11/30/2011 03:28:04.66 AM DynConfig> Found $DPLocked field: $DPLocked on policy note.  Copying to location doc
[2134:0002-1898] 11/30/2011 03:28:04.66 AM DynConfig> Found $DPLocked field: $DPLockedUnstripped on policy note.  Copying to location doc


Just a little FYI that might explain some strange stuff that is happening.

Anyone planning on going to Lotusphere?  I certainly am.  Where else can I see all my old friends in one spot!

-Andy

Comments

1Mike Kinder  12/2/2011 9:33:14 PM  Slight issue with Domino directory locking policy fields by default

Thanks for sharing this Andy, though as of right now it does not impact me at all.

As for LSphere - not sure I'll make it this year, but the possibility does exist.

Hope all is well with you guys.

2Brian Wert  12/16/2011 4:35:37 PM  Slight issue with Domino directory locking policy fields by default

I also found that the replication repeat interval field in the policy subform is set to 60 minutes and the apply setting is set to 1 which is don't set value but my clients with Lotus Notes 7 are getting their replication repeat interval changed by the policy. Even if they change the value it defaults back to 60 minutes. I don't even have any replication settings being pushed out by the policy.

See you at the Sphere.. : )

"Test"