Head in a blender

Incorrect alias returns

Andy Pedisich   November 24 2014 09:35:17 AM
Weird issue. All names have been changed to protect the innocent.

User's address is john.smith@mycompany.com.  Suddenly when customers reply to his emails they are coming in to Image:Incorrect alias returns. I check DIP files in the workspace folder and find that the address with bad alias is showing in recent contacts. Then everything John.smith@mycompany.com sends out has the return address of Image:Incorrect alias returns.

I check location documents and person documents in the directory and there is no alias/email address that looks like this one.

I turn off recent contacts and blow away the all the DIP files that control recent contacts for the dynamic personal address book.  Problem solved.  People who have already corresponded with John are still using Image:Incorrect alias returns, but that is out of my control.  I can't contact customers and have them delete the old address they are using. But the problem seems to not happen for new users.

Recently, John visits a new customer in person and gives the customer his email address verbally.  The customer writes it down as john.smith@mycompany.com.  Customer sends his first ever email to John and it comes in addressed to Image:Incorrect alias returns.   Arrgh.

Anyone ever seen something like this where a bad alias is perpetuated?  There is a cloud based antiviral solution between that scrubs all mail between customers and John, but there are no alias names for John in the AV solution.

Weird, isn't it?

-Andy
Comments

09:35:17 AM November 24 2014

"Test"